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Unit 4 – Introduction to 2D Animation Package & Scripting Language

What is Flash?
 Macromedia Flash is a multimedia graphics program especially for use on

the Web.
 Flash enables you to create interactive "movies" on the Web.
 Flash uses vector graphics, which means that the graphics can be scaled to

any size without losing clarity/quality
 Vector-based content and applications download faster than their bitmap

equivalents. Streaming data content appears immediately, without having
to wait for the entire piece to download.

The Timeline

The Timeline is the essence of Flash. This is where your work comes alive in the
form of animation. Although it may not be clear at first how the Timeline works,
its use will become almost intuitive as you gain experience in working with Flash.

The Timeline represents all the frames in your movie. Like a cell-animated
cartoon, the illusion of movement is attained by rapidly displaying the contents of
a sequence of frames, just like a flip-book animation. Flash can handle several
different types of animation – frame-by-frame, motion tweening, and shape
tweening. All three animation techniques are conveyed by the Timeline.

The Timeline panel, including the layers section

There are many details to the Timeline. Each block or t ick mark
represents a single frame. Frames are numbered in increments of 5 (by
default) along the top. The number of frames in a Flash movie can vary
depending on the length of the movie. You can use the scrollbar below
the frames to see frames not currently displayed in the Timeline. Also
notice that the numbers increase from left to right—this is the order in
which your movie will play, at the designated frames per second (defined
in the Document Properties dialog box).

The Playhead is the red rectangular marker located within the frame
numbers. Its position designates which frame is currently displayed on
the stage. To move the Playhead, click and drag it left and right to see
how your movie behaves.
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Layers
Flash provides a way to create layers in your animation. Using layers, you can
organize the contents of an animation and separate different objects or groups of
objects. As you work with your animation, you can hide layers to prevent the
stage from getting cluttered and unwieldy, and / or you can lock layers to prevent
accidental changes to the objects on them. Overall, layers are a very useful tool
in organizing the objects in your Flash movie, and, particularly in the case of
some animation techniques, are required for the animation to work properly.
Never be concerned with creating too many layers; having too many layers is
better than having too few.

The layers are shown as a stacked order in the layers section of the Timeline
panel, meaning that they are all physically stacked on top of one another on the
stage. A higher-positioned layer will cover anything below it. Objects on lower-
positioned layers will not be visible if there is a shape in a higher layer that is
drawn on top of it.

The layers section of the Timeline panel

 To add a new layer, click on the Insert Layer icon on the Timeline panel.
This will insert a new layer directly above the layer that is currently
selected.

 Be sure to make it a habit of naming your layers for better organization.
Double click the layer name to change it.

 You may also easily rearrange the order of your layers by clicking a layer
and then dragging it to the selected location among the rest of the layers.

 To delete a layer, select it by clicking on the layer name and then clicking
on the trash can icon

Frames
Each image is called a frame. In movies, frames are the individual pictures on the
film itself. In Flash, frames are the little rectangular cells in the Timeline. They’re
numbered at the top of the Timeline, and every fifth frame is gray; the rest of the
frames are white with a gray outline. The Timeline displays all the frames, but
normally you can look at the contents of one frame at a time. The red current-
frame marker can be in only one place at a time—the frame you’re currently
viewing. You don’t draw into a frame on the Timeline—you draw onto the Stage.
The current-frame marker indicates the frame whose contents are currently
onscreen.
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Key frame
A keyframe is simply a frame in which you establish exactly what should appear
on the Stage at a particular point. A keyframe might include an image, or it might
be blank. A blank keyframe is still a keyframe; it’s just one in which nothing
appears on the Stage.

A Keyframe is a frame in the Timeline where something new appears. All new
objects need a Keyframe. A Keyframe is represented by a solid dot in the
Timeline:

The Black dots are the Keyframes

You can also have empty Keyframes. These are Keyframes that do not yet have
an object. Empty key frames are denotes by a small circle in the Timeline:

A series of empty Keyframes in the Timeline

Empty Keyframes are often used to hold ActionScript. In which case you will see a
small 'a' in the Timeline. Either type of Keyframe can hold ActionScript:

Both types of keyframes can hold ActionScript

Tip: If a keyframe is not needed delete it. It helps simplify your Movie: Right
Click on the Keyframe and select: Clear Keyframe.
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Toolbox

There are many basic drawing tools available in Flash. Each is detailed below.
Also note that many of these tools have additional options or modes that can be
changed in the Options area of the Tools panel.

The first important tool is the Selection tool. This tool is used to
make selections on objects and graphics on the drawing area, or stage.
You can either click on individual objects to select them, or click and
drag to make a rectangular region and select all the objects in it. Once
you make a selection, you may perform subsequent actions that affect
your selection, such as moving it around the stage, deleting, or altering
it in the Properties panel. Hold down the SHIFT key to select multiple
individual objects.

The Subselection tool is used for selecting and modifying anchor
points on curves and lines. Clicking once on a line or curve with the
Subselection tool reveals the anchor points. Anchor points are
represented either by a hollow square (a corner point), or a hollow
circle (a curve point). Clicking on an anchor point with the Subselection
tool will select that anchor point (then represented by a filled square or
circle). You can then click and drag the anchor point to move it, ALT-
click and drag on a corner point to convert it to a curve point (and thus
reveal anchor point tangent handles), or ALT-click on a curve point to
convert it to a corner point (and thus remove the tangent handles).

The Line tool is an important drawing tool. It functions like the line
tool in other drawing programs. To use it, click on the stage, drag, and
release to draw a straight line. Stroke width, style, and color can be
changed in the Properties panel. Hold down the SHIFT key while

dragging to constrain the line angle to increments of 45°.

The Lasso tool can be used to select objects on the stage. It allows creating
a freeform selection area by clicking and dragging around an area. When you
release the mouse button, Flash automatically completes the loop with a straight
line.

The Pen tool is used to create precise paths that are either straight lines or
smooth curves. Stroke width, style, and color, and fill color (for closed paths) can
be changed in the Properties panel. To use the Pen tool to create straight lines,
click anywhere on the stage to define the first anchor point, click again where you
want the first segment of the straight line to end (hold down the SHIFT key to
constrain the line to increments of 45°), and continue clicking to create more
straight line segments. Double click the last point to end the line segments (and
create an open curve), or click on the first point you created to close the curve.
To create curved lines, follow the same procedure, but instead of simply clicking
to create each point, click and drag in the direction you want to curve to go.
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The Text tool allows you to draw text on the stage. Position the cursor on
the stage where you want to begin your text and then click and start typing. The
text font, size, color and paragraph formatting can be changed in the Properties
panel.

The Oval tool allows you to create ovals of any shape and size (including
circles). Stroke width, style, and color, and fill color for ovals can be changed in
the Properties panel. To create an oval, simply click and drag across the stage to
create the oval as you want it. Hold down the SHIFT key while dragging to
constrain the oval to a circle.

The Rectangle and PolyStar tools allow you to create rectangles and
polygons. To switch between the Rectangle and PolyStar tools, click and hold the
tool icon on the Tools panel, then select the desired tool from the menu that
appears. Stroke width, style, and color, and fill color for rectangles and polygons
can be changed in the Properties panel. In addition, for the PolyStar tool, the
number of sides of a polygon, or points on a star, can be changed by clicking on
Options in the Properties panel. To create a rectangle or polygon/star, simply
click and drag across the stage to create the shape as you want it. While using
the Rectangle tool, hold down the SHIFT key while dragging to constrain the
rectangle to a square. While using the PolyStar tool, hold down the SHIFT key to
constrain the orientation of the polygon or star to increments of 45°.

The Pencil tool is used to create lines and shapes on the stage in much the
same way you would use a real pencil. Stroke width, style, and color can be
changed in the Properties panel. To use the Pencil tool, click and drag across the
stage to create a line. Note that you can end your drawing at the same place you
started, but the shape you create is not filled in. Hold the SHIFT key while
dragging to constrain the line to a horizontal or vertical direction.

The Brush tool is used much like a paint brush. Click and drag across the
stage to paint. The fill color can be changed in the Properties panel. Note that no
stroke is produced when using the brush tool. Under the Options section of the
Tools panel, you can change the brush size and shape.

The Free Transform tool can be used to transform objects in a variety of
ways. To use the tool, click on an object on the stage to reveal transform handles.
Then, under the Options section of the Tools panel, choose the type of
transformation you want to perform. Options include Rotate and Skew, Scale,
Distort, and Envelope. Hold down the SHIFT key while rotating to constrain the
angle to increments of 45°.
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The Fill Transform tool allows you transform gradient and bitmap fills. To
use it, click on an object that has a gradient or bitmap fill to reveal transform
handles. Click and drag the circle handle in the center of the fill to move the
gradient or bitmap. To change the width or height of a bitmap fill, or the scale of
a gradient fill, click and drag the square handle along the edge of the fill bounding
box. To rotate the fill, click and drag the circle handle on the corner of the
bounding box. To change the radius of a circular gradient fill, click and drag the
middle circle handle on the bounding circle of the fill.

The Ink Bottle tool allows you to change the stroke color, width, and style
of lines and shape outlines. To use it select the stoke width, style, and color you
want to apply in the Properties panel, and click on one or more lines or shapes on
the stage to apply the stroke properties to them.

The Paint Bucket tool allows you to fill enclosed areas with color. To use it,
select the solid color or gradient you want to apply in the Properties panel, and
click on one or more enclosed shapes on the stage to fill them with color. Note
that under the Options section of the Tools panel, you can choose how you want
Flash to handle partially enclosed areas.

The Eyedropper tool allows you to copy stroke and fill properties from one
object to another. To use it, click on a stroke or fill of the object whose properties
you want to copy. If you click on the fill, the Eyedropper tool automatically
changes to the Paint Bucket tool, with fill properties set the same as the object
you clicked on. If you click on the stroke, the Eyedropper tool automatically
changes to the Ink Bottle tool, with stroke properties set the same as the object
you clicked on. Now click on one or more objects on the stage to apply the stroke
or fill properties.

The Eraser tool allows you to erase objects on the stage. To quickly erase
everything on the stage, double click the Eraser tool icon on the Tools panel. Note
that you can change erasing options in the Options section of the Tools panel.

The Hand tool is used for moving the view of the stage. It is especially
useful when you have used the Zoom tool to magnify the stage. To use it, simply
click and drag the stage in the direction you want it to move. To temporarily
switch between another tool and the Hand tool, hold down the spacebar and click
the Hand tool in the Tools panel. When done dragging, Flash will return to the tool
you were using.

The Zoom tool is used for magnifying or reducing the view of the stage. To
use it, click anywhere on the stage to zoom in by a factor of two. Alternatively,
you can click and drag to zoom into a region of the stage. Hold down the ALT key
while clicking to zoom out by a factor of two.

In addition to the drawing and view tools, the Tools panel allows
you to modify the colors that are used to draw strokes and fills. The Stroke color
is applied to lines and shape outlines. The Line, Pen, Oval, Rectangle, PolyStar,
and Pencil tools all produce a stroke. The Fill color is applied to the interiors of
shapes. The Pen (for closed paths), Oval, Rectangle, PolyStar and Brush tools all
produce fills.
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Symbol

A symbol is a reusable object used/created in Flash. A
Symbol can be reused throughout your movie or
imported and used in other movies. There are three
types of symbols: Graphics, Buttons, and Movieclips.

A copy of a symbol used in the movie is called an
Instance, which can have its own independent
properties (like color, size, function, etc.) different from
the original symbol. All symbols used in a flash movie
are stored in the Library from where you can drag-
and-drop new instances of the symbols into your movie.
When a symbol is edited all of its instances get
updated, but changing the properties, effects or
dimensions of an instance of a symbol does not affect
the original symbol or other instances.

Importance of using Flash Symbols
Using flash symbols is very crucial to the file size of your Flash movie. The Flash
file size depends largely on the size of all the graphics and texts used in the
movie (both symbols and non-symbols) - here the major advantage of using
symbols is that a symbol's size is taken into consideration only once even if it is
used a hundred times - this is the true power of Flash. Unused symbols in your
library are not counted in the size of your movie.

The Three Types of Symbols
Graphic symbols are reusable static images that are used mainly to create
animations. Any drawn vector/plain text/imported bitmap (photo), or
combinations of these, can be converted into a single controllable object: as a
graphic symbol. They have only one frame in their timeline.

Button symbols are used for timeline navigation - They add interactivity to the
movie and respond to mouse clicks, key press or rollovers/rollout, and other
actions. You define the graphics associated with various button states
(Up/Over/Down/Hit), and then assign actions to the instance of a button. They
have 4 frames in their timeline - one each for the up, over and down states, and
one to define the hit area of the button.

Movieclip symbols are reusable pieces of flash animation - consisting of one or
more graphic/button symbols - thus they are flash movies within your flash
movie. They have their own non-restricted Timeline (any number of layers and
frames - just like the main timeline) that plays independent of the main movie's
Timeline. The best thing about using movieclips is that you can control them from
actionscript - you can change their dimensions, position, color, alpha, and other
properties and can even duplicate and delete them.
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How to create a graphic symbol in Flash

Please carry out the following steps in Flash to create graphic symbols.

1. First create/import the object(s) to be converted into a graphic. You can
import bitmaps onto the stage using Ctrl+R.

2. Select the object(s) and then press F8 (or Modify >> Convert to Symbol).
3. Select the Graphic Behavior and name the symbol, say 'g_home'.
4. To edit it at a later point, double-click the symbol in the library (Ctrl + L) or

any of its instances on the stage to switch to its symbol-editing mode as
shown below. The name of the symbol will appear near the scene name
('Scene 1' by default, as shown below).

5. Make the necessary changes and click 'Scene 1' to exit from the symbol
editing mode and go back to view the main movie's time-line.

Fig: Symbol-editing Mode of flash graphic 'g_home' (Flash 8 and below)

How to create a button symbol in Flash
Button symbols are used for timeline navigation. The button symbols add
interactivity to the movie and respond to mouse clicks, key press or
rollovers/rollout and other actions. You can define the graphics associated with
various button states (Up/Over/Down/Hit), and then assign actions to the
instance of a button. There are 4 frames in their timeline -one each for the up,
over and down states, and one to define the hit area of the button.

Please carry out the following steps in Flash to create button symbols.

1. First create/import the object(s) to be converted into a button. Import
bitmaps onto the stage using Ctrl+R.

2. Select the object(s) and then press F8 (or Modify >> Convert to Symbol).
3. Select the Button Behavior for the symbol and name the symbol say,

'btn_home'.
4. Double-click the instance of 'btn_home' on the stage to switch to its

symbol-editing mode. The Timeline header changes to display four
consecutive frames labeled Up, Over, Down, and Hit as shown below.
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Fig: Symbol-editing Mode of completed flash button 'btn_home'

5. The first frame displays the drawn vector/plain text used for creating this
button, now insert a Key frame (F6) in the frame labeled Over (Flash
automatically duplicates the contents of the Up frame).

6. Now change the color of the object in the Over frame to create a rollover
effect in the button.

7. Insert frames (F5) for the Down frame and the Hit frame (only defines the
area of the button that responds to user action and is not visible at
runtime).

8. Save your work and test the Movie (Ctrl + Enter). That's it your simple
button is ready!

How to create a movieclip symbol in Flash
Movieclip symbols are reusable pieces of flash animation - consisting usually of
one or more graphic and button symbols - thus they are flash movies within your
flash movie. They have their own non-restricted Timeline (any number of layers
and frames - just like the main timeline) that plays independent of the main
movie's timeline.

The best thing about using movieclips is that you can control them with ease -
you can change their dimensions, position, color, alpha, and other properties and
can even duplicate and delete them. Thus any object that needs to be controlled
using flash actionscript (no matter how simple or complex it might be) needs to
be a movieclip with an instance name that is called in the actionscript code.

Please carry out the following steps in Flash to create movieclip symbols.

1. First create/import the object(s) to be converted into a movieclip. Import
bitmaps onto the stage using Ctrl+R.

2. Select the object(s) and then press F8 (or Modify >> Convert to Symbol).
3. Select the Movieclip Behavior and name the symbol, say 'mc_fade').
4. Double-click the instance of 'mc_fade' on the stage to switch to its symbol-

editing mode. Now create an animation sequence (you can use simple
Tweened Animation or Frame-by-Frame Animation).
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Fig: Symbol-editing Mode of completed flash movieclip 'mc_fade'

5. The above figure shows the Timeline of the Movieclip symbol. Click Scene 1
to exit from the symbol editing mode.

6. Save your work and test the Movie (Ctrl + Enter). That's it your movieclip is
ready!

Types of Animation
There are three types of animation in Flash – Frame-by-Frame , Motion tween,
and Shape tween.

Frame-by-Frame Animation
By learning frame-by-frame animation, you will have a better understanding of
how the Timeline works and how you can control it.

1. First, create a shape in one layer on the stage, say, a rectangle. Notice the
frame in the Timeline has a black dot after you have created the circle –
i.e., it becomes a keyframe. Keyframes designate points in animation
transitions and reflect changes in animation as the movie progresses.

The first frame becomes a keyframe when you place an object on the stage
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2. Now, click on frame 2 in the layer and go to Insert > Keyframe, or press the
shortcut key, F6. Another keyframe will be created and your rectangle will
be automatically placed on the stage in the second keyframe.

3. If the rectangle is not highlighted as a fine checkerboard pattern, use the
Selection tool to draw a selection box around the rectangle.

A checkerboard pattern indicates the graphic object is selected

4. Now, hold down the SHIFT key and press the down arrow on the keyboard
to move the rectangle down a few pixels. (Without the SHIFT key pressed,
the rectangle will move one pixel at a time.)

The rectangle moves further down in the next keyframe

5. Click the next frame in the layer and insert another keyframe (F6).

6. Move the rectangle down again in the same manner.

7. Repeat this process until you have 12 keyframes, each with the rectangle
moving down a little further than the last time. Now, if you slide, or “scrub”,
the timeline playhead back and forth from the first to twelfth frame, you will
notice that the rectangle “moves” up and down.
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8. Move the playhead to the first frame and press Enter on the keyboard to
play the movie. Congratulations, you have created your first Flash
animation!

9. To preview your movie as it will play in real time, press CTRL-Enter. Watch
how your animation plays and repeats. Close the movie to return to Flash.

Frame-by-frame animation is rarely used in Flash. Its use is mainly confined to
animation sequences that require exact positioning and strict rates of change.
Another circumstance to use frame-by-frame animation is to display imported
movie file images.

Tween Animations
Macromedia Flash provides two main ways of animating, Tweening and Keyframe
Animation. The most common form is Tweenng where you set a starting point and
an end point and let the program animate the objects BETWEEN them. This is
where the term TWEEN comes from.

Creating a Motion Tween
Motion Tweening involves moving objects from a starting point to an end point.
You can motion tween objects, text, drawings, etc. They must be grouped or
converted to a symbol.

1. Create a new Flash movie by selecting File > New and choosing Flash
Document under the General tab.

2. Create a rectangle on the stage of any color and size. Use the Selection tool
to draw a selection box around the rectangle.

3. Go to Modify > Convert to Symbol or press the shortcut key F8. A popup
dialog will be shown.

The Convert to Symbol dialog box

4. Name this symbol Rectangle and be sure to select the graphic subtype by
clicking the Graphic radio button. Click OK. The checkerboard pattern on
the rectangle disappears and a plus sign appears at the top left corner of
the rectangle, indicating that it has successfully become a symbol.
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A Rectangle symbol on the stage

5. Now, to animate it via motion tweening, click frame 12 (or whatever frame
you want your animation to end on) in the timeline on the Rectangle layer
and go to Insert > Timeline > Keyframe or press F6.

6. Use the Selection tool to select and drag the rectangle to a new position on
the stage, noticeably far from its original position. You should have two
keyframes in this animation: one at the beginning and one at the end of the
layer with the rectangle on it.

7. Click on any frame between the first and last keyframes of the layer with
the rectangle on it and choose Motion from the Tween menu on the
Properties panel (or go to Insert > Timeline > Create Motion Tween) and
you should see that Flash replaces all the grey frames between the first and
last keyframes with a blue background and an arrow. This is the
representation of a Motion Tween on the Timeline.

Motion tweening has been selected for these frames

8. Move the playhead to the beginning of your movie and press Enter. Your
rectangle should move in increments from its starting position to its final
position. This animation is essentially the same as your frame-by-frame
animation but you did not have to fill in every step, just the first and last.
Flash automatically interpolates the position of your symbol between
keyframes. This is why it is important to designate keyframes – to specify
beginning and end points of animations.

9. Now, let’s make the rectangle move some more, this time in a direction
perpendicular to the original direction. Click on frame 24 and create a
keyframe (F6). Use the Selection tool to move the rectangle to a new
location. Create motion tweening just as before and play your movie. By
repeating this process, you can extend the length of your movie by creating
more motion tweens between additional keyframes.
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Creating Shape Tween Animation
Shape tweening is another method you can use for creating animations. Another
term for shape tweening that you may be familiar with is “morphing.” It is an
animation technique that transforms one shape into another. Like motion
tweening, shape tweening is accomplished by using a start and an end keyframe.
Unlike motion tweening, however, shape tweening does not use symbols.

1. Create a new Flash movie by selecting File > New and choosing Flash
Document under the General tab.

2. In the first frame of Layer 1, create a filled circle of any color on the stage.

3. Next, click into, say, frame 24 of Layer 1 and press F6 to place a keyframe.

4. Notice that the contents of the first keyframe are copied into the second
keyframe when you press F6. However, you want to transform your circle
into a different shape, so press delete to remove the circle from the stage
(make sure that the circle is first selected).

5. Create a rectangle on the stage.

6. Finally, click on any frame between the two keyframes and select Shape
from the Tween menu on the Properties panel. Also, if your shape to be
tweened has angles and straight lines, choose Angular from the Blend
menu on the Properties panel. If not, choose Distributive. Once you do
this, the frames between the key frames will become an arrow in front of a
light green background. This is the representation of a Shape Tween on the
Timeline.

7. Slide, or scrub, the playhead to the beginning of your movie and press the
Enter key. Your movie should play and you should see the circle becoming
a square.

First frame of shape tweening: circle

Not only do shapes change, but colors may undergo a transformation too. Go to
the keyframe in Frame 24 to highlight your shape and select a different color from
the Fill Color tool. Now play your movie again. You should see a smooth color and
shape transition. As in motion tweening, you may adjust some frame parameters,
such as easing, to alter movie playback.
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An intermediate frame in the shape tweening; becoming a square

Onion skinning
Onion Skins are an editing option that lets you view many Frames at once. In the
Timeline you ordinarily only see the contents of the current Frame. Onion Skins
enables you to see the progression of an animation:

Position of the word Bounce in Frame 56 in a Motion Tween animation.

Onion Skin Button
Switch the Onion Skins on by going to the Timeline and clicking the Onion Skin
button:

You can now see the Frames to both sides of the selected Frame.
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Onion Skin Handles
Drag the Onion Skin Handles to change the range:

The animations path up to the current Frame.

Onion Skin Outlines
Press the Onion Skin Outline button to see the Frames in Outline:

Onion Skins in Outline.

Edit Multi Frames
If you want to move or edit the objects from several Frames at once try the Edit
Multi Frames button:
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Editing multiple Frames at once.

Onion Skin Options
Click the Modify Onion Markers button:

You will see this menu.

Always Show Markers: Displays the Onion Skin Markers in the Timeline
whether or not Onion Skinning is on.

Onion On. Onions Off!

Anchor Onion: Locks the Onion Skin Markers to their current position in the
Timeline header. This means that if you move the Playhead the Markers stay in
place.

The Playhead is outside the Onion Skin area (so not visible).



US05CBCA02 – Computer Graphics Unit - 4

V.P. & R.P.T.P SCIENCE COLLEGE, VV NAGAR 18 | P a g e

Onion 2: Displays 2 Frames on either side of the current Frame:

Onion 5: Displays 5 Frames on either side of the current Frame:

Onion All Displays all Frames on either side of the current Frame:

The path of the entire animation.
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Importing images into Flash
Drawing in Flash takes time and practice to achieve the exact look that you want.
However, if you already have a graphic that you want to use, Flash has the ability
to import graphics of different types, namely JPEG, GIF, and BMP. These graphics
are usually the ones that you encounter on a typical website, and can be edited in
graphics programs such as Adobe Photoshop.

1. Create a new Flash movie by selecting File > New and choosing Flash
Document under the General tab.

2. Create a keyframe (F6) in the first frame of the first layer.
3. Next, go to File > Import to Stage.
4. Choose the graphics file that you want to show up on the Flash stage and

click OK.
5. The graphic will be placed in the middle of the stage and it is treated as a

semi-Graphic symbol, meaning that you can create a motion tween
animation right away without having to convert it into a Graphic symbol
first.

Because you are manipulating bitmapped images that are not vectors, the file size
of this Flash movie will usually be much higher than a vector-only based Flash
animation. Keep this in mind when you are developing for a high traffic website,
as you would want to keep the download sizes to a minimum.

Exporting images from flash
Selecting the menu option File -> Export Image produces a list: of "save" options
that convert selected frames of your movie into static graphic images. You can
select these file types by choosing from the format options shown in figure.
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Publish Setting
1. When you are ready to publish your movie go to: File > Publish Settings.
2. Under the Format tab select: Flash and HTML.

Flash and HTML selected under the Format Tab

3. Go to the tab: Flash
4. For Version select: Flash Player 7
5. For ActionScript version select: ActionScript 2.0

The latest Player and Version of ActionScript have been selected.

6. Next go to the tab: HTML
7. Select: Detect Flash Version
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Detect Flash Version has been selected.

8. Click on the button:

9. If you wish to you may change the names of the files in the Version
Detection Settings dialog box, but there is no need. I only got you to open it
so that you can see what Flash is going to do when you publish your movie.
To close the Version Detection Settings dialog box click: OK

10. To Publish your work click the Publish button:

11. To close the Publish settings dialog box click: OK
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Guided Layer
Guide Layers do not publish with the final Flash Movie so you can place objects in
a Guide Layer and they have no impact on the Final Movie. To create a Guide
Layer right click on the Layer name and select Guide.

Adding a Guide Layer

A Guide Layer has a special Blue Hammer Symbol icon:

Alpha effect
This is the most used effect due to the fact of controlling the degree of the object
transparency. Alpha effect is generally used to give effect like transparent, fade
in, fade out, shadowing etc. Following is an example to give fade effect to images
in flash.

1. Open a new file. Go to File >New. A Screen called New Document will
appear. Select Flash Document and click on OK. Go to Modify>Document
and give a file size of 300px by 200px. This is the same size as the Bitmap
pictures we have.

2. Select the Bitmap pictures that you want to Fade in and Fade out from your
picture file and bring it to the Flash Library. Select File>Import to Library
from the Menu Bar. A Screen named Import To Library will open. Choose
the file name and click on Open. Repeat these steps for all the Bitmap
pictures. To open Library, go to Window>Library. You can see the
pictures in the Library panel.
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3. Drag the picture from the Library panel to the Stage. Select the picture by
clicking on it. Go to Modify>Convert To Symbol from the Menu Bar. A
dialog Box named Create New Symbol will appear. Give the name as
pic1_mc. Select Movie Clip. Click on OK.

4. Click on your Movie Clip. Go to Frame 15. Insert a Keyframe. Right click on
layer 1 in the middle of the frames 1 to frames 15. The frames will become
black. Select Create Motion Tween. An arrow from frame 1 to frame 15
will appear. Again click on Frame 30. Insert a Keyframe. A second arrow will
appear automatically.

5. Click on Frame 1. Here we will give the fade in effect. Select the picture by
clicking on it. Go to Properties in the panel below the Stage. Go to
Color>Alpha give 0% to it.

Your picture has faded in. Click on Frame 30. Here we will give the fade in
effect. Select the picture by clicking on it. Go to Properties in the panel
below the Stage. Go to Color>Alpha give 0% to it.

6. Repeat the steps 3 to 5 in layer 2 from the frame 31 to 45 to 60. To make a
new layer, click on the following button which is on the right side below
the layers. Repeat the above steps for all the images in new layers and you
will create a simple fade in and fade out Flash animation.

Press on Ctrl+Enter to see the Fade in & Fade out Effect of the 4 pictures.

Color Properties
Color contains various properties like alpha, brightness, tint etc. All the properties
are used to give various effects on text and images.

Each instance on the Stage can have a color style applied to it. Styles include
tinting the color of an instance and changing an instance’s alpha property (that is,
its opacity). Similarly to how each instance can have a different location, each
instance can have different color effects. To move an instance, though, you just
pick it up and move it. To apply a style, you use the Properties panel.

To change an instance’s color style, you simply make sure the Properties panel is
visible and select the instance on the Stage. While the instance is selected, you
can specify any style you want by selecting from the Color drop-down list.
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Brightness—This effect allows you to add black or white to the instance. It is
similar to turning the lights out or turning them way up.

Tint—This effect is similar to brightness, but instead of causing the instance to be
more white (or more black), it tints the instance any color you want.

Alpha—This effect, which is the same as opacity, lets you specify how “see
through” the instance will be.

Advanced—This effect lets you combine tint and alpha.

Masking
Masking is an animation technique used to give special effects like ripple effect to
graphics as well as text. Masking involves two layers: one Mask and one Masked.
They must be directly adjacent, with the Mask layer on top of the Masked layer. If
the new layer you added is between the two, changing it to Normal will require
the old Masked layer to be Normal, too. You have to get that new layer out of the
shadow of the mask before you change it to Normal.

The basic orientation of the Mask and Masked layers is similar to the Motion
Guide/Guided layer arrangement. For masking, you first specify one layer’s Type
property as Mask. Then, you’ll find the Masked setting available when you access
the layer properties for a layer directly below the Mask layer. However, you won’t
actually see the masking effect unless you test the movie or lock all the layers
involved.

You can do some sophisticated stuff with masking. For example, you could edit
the master version of Spot and maybe cut out part of the fill (by using the Lasso
tool). The Masked layer will show through only where there’s something in the
Mask layer. Unfortunately, this is an all-or-nothing situation. That is, the mask is
either on or off. You can pull off the effect of a graduated mask by putting the
graduation in the Masked layer (because it won’t work in the Mask layer). Another
idea is to make a duplicate of the Spot symbol—but one with a transparency
gradation fill. Then you can make a separate layer where this duplicates follows
the same path as the spot.

Example of masking using filled shape
1. Inserting Layers and Naming them

a. By default you will have a layer in your timeline window. Insert one
more layer, totally you need two layers to mask an object.

b. Rename the top layer to "Mask" and the layer below that to
"background".

2. Creating Shape Tween
a. Import your picture to the "background" layer.
b. Using Oval tool from your tool box, draw a circle in your "Mask" layer

and delete it's border.
c. Drag the circle to one end of your picture.
d. Now go to "frame 40" of your "Mask" layer and press "F6" to insert a

new keyframe.



US05CBCA02 – Computer Graphics Unit - 4

V.P. & R.P.T.P SCIENCE COLLEGE, VV NAGAR 25 | P a g e

e. Now go to "frame 40" of your "background" layer and press "F5" to
insert frames, so that your background image is available all through
your mask.

f. Select "frame 40" of your "Mask" layer, that is your new keyframe,
keeping the playhead on "frame 40" of "Mask" layer, drag the circle to
other end of your picture.

g. Now go back to "frame 1" of your "Mask" layer, keeping the playhead
on "frame 1" of your "Mask" layer, select Shape tween in your
properties window.

3. Masking
a. Right click on the "Mask" layer (the area where you named the layer

not where the frames exist) and select Mask.
b. Your Mask is all ready. Press Ctrl+Enter to view your Mask.

Example of masking text
Step 1
In Frame #1, create the text that you want to show through the hole in the mask.
Insert a Frame (F5) at frame 40.

Step 2
Insert a new layer (Insert > Layer) ABOVE the layer with your text.

New Layer
Text Layer

A mask layer will automatically mask the layer directly below it, so make sure you
have them in the right order.

Step 3
Create a filled in circle and make it a Graphic Symbol (F8). Color does not matter.
On a mask layer, anything filled becomes transparent and vice versa. Make it
large enough to where it is taller than your text, and place it to the left hand side
of your text. On this same mask layer, insert a Keyframe (F6) at frame 20 and
move the symbol to the right side of the text. Insert a Keyframe at frame 40, and
move the symbol back to the left.

Step 4
Select frame 1 in the timeline. In the Properties Inspector (if it's not showing
below your workarea, Window > Properties), from the Tween drop-down box,
select Motion. Set Ease to 100 (Out). Now do the same at Frame 20.

Step 5
One last step is to set the mask. Right click on your top (mask) layer, and choose
Mask from the menu options. This should lock both layers. To do further editing,
you will need to unlock the layers (by clicking the lock symbol on the layer).

Test your movie.
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Motion Guide
A Guide layer that has an adjacent layer (below it) that is set to Guided. Tweened
objects in the Guided layer will follow a path in the Guide layer. Essentially, a
motion guide is a path for your graphic symbol to follow from the first keyframe
to the last keyframe.

1. Create a new Flash movie by selecting File > New and choosing Flash
Document under the General tab.

2. Draw a shape of any kind on the stage. Select it and turn it into a symbol
(F8). Remember to make it a Graphic symbol.

3. Select the layer that contains your symbol, and click the Add Motion Guide
icon . A new guide layer will be formed above your first layer, which is
now indented to indicate that it is affected by the guide layer above it.

A guide layer that affects Layer 1

4. In the first frame of the motion guide layer (not the layer itself), use the
Pencil tool to draw a path that you want your symbol to follow. Be sure your
path is continuous – it should not have any breaks in it.

5. Now, insert a blank frame in the motion guide layer to indicate when you
want your animation to end. You can do this by clicking on, say, frame 50
of the motion guide layer and going to Insert > Timeline > Frame or
pressing F5. The motion guide layer is now set and you are ready to
position the start and end point of your animation.

6. Click on the keyframe in frame one of Layer 1 (the layer with your symbol).
Use the Selection tool to drag the center point, displayed as a circle, of your
symbol to the start of your motion guide – your symbol should snap into
place, and this confirms that it is the beginning point of your animation.

7. Insert a keyframe (F6) in Layer 1 at the end of your animation, in this case,
frame 50. In this keyframe, use the Selection tool to position your symbol
at the end of the motion guide. Again, align the center point of your symbol
with the end of your motion guide path.
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8. Finally, click on a frame between the two keyframes of Layer 1 and select
Motion from the Tween menu on the Properties panel (or go to Insert >
Timeline > Create Motion Tween). Your animation is now ready to play.
Below is how your setup should look:

9. Press the Enter key to preview your animation. It should follow your motion
guide perfectly.

a. The motion guide line is visible when you are working on a Flash
animation. However, it will not appear in the actual movie. You can
preview the actual movie by pressing CTRL-Enter.

b. One parameter that you can adjust for motion guide tweening is
Orient to Path. If set, this means your symbol will rotate as it moves
along the path, instead of always remaining in its original orientation.
To turn this option on, click on the first keyframe of Layer 1 and
select Orient to Path in the Properties panel.

Play your movie (Enter key or CTRL-Enter) to see how the animation is altered.

Movie Clip Mask
We can also mask a movie clip in flash. By applying a mask on a movie clip, you
can restrict the visible area of the target clip to the mask area. Below is a simple
example.

In this example there are three buttons. When user clicks on any button, some
effect will be shown.
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When user clicks on “Show Target” Button, it will show:

When user clicks on “Show Mask” Button, it will show:

When user clicks on “Apply Mask” Button, it will show:

Step 1
Open a new file in Flash editor. Draw whatever you like as the target clip on the
main stage.

Step 2
Insert a new layer above the orginal layer. Draw your mask shape there. Right
click on the new layer and select "mask" in the pop up menu. The timeline will
look like:

This means the mask has been applied to the target clip.
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Action Script
ActionScript adds interactivity to a Flash animation. ActionScript is a proprietary
scripting language that controls the playback of a Flash animation, and can be
very complex.

Snippets of ActionScript code, or simply actions, can be associated with a number
of objects in a Flash animation. For example, you can associate actions with a
particular frame of your animation. This will cause those actions to occur when
the Flash player gets to that frame. You can also associate actions with events,
such as when you click on a button, or when a movie clip is loaded into the Flash
player. In this document, we will cover two ActionScript functions. Functions are
built-in actions that are available for use in your Flash animation. The first
function, stop(), will be associated with a frame. The second function
gotoAndPlay() will be associated with an event, specifically, the clicking of a
button.

Play() Action
After we use the stop() action to halt a movie, we use the play() action to resume
play. In some scenario of stopping the movie to display a large block of text, we
assign the stop() action to keyframe and assign the play() action to an invisible
button behind the text. We also use the play() action when creating a pop-up
menu. Following example shows the play action assigned to a button. In this
case, the action occurs when the user releases the mouse button.

on (release) {
play();

}

Stop() Action
When you need to halt the action in a movie, the stop action will do it for you.
The stop action has no parameters. When the flash players see this action in one
of your scripts, it stops the movie. We can use this action to stop the movie while
viewers read a large block of text. We also use this action as part of drop-down
menu. We can use the stop() action on a keyframe of button. We have to just
write stop() to stop the movie on appropriate object is clicked.

getURL Action
With the getURL() action, we can open another web page from our flash design.
We can assign the action to button or keyframe. We assign the getURL action to
the final frame of Flash intro to open a site’s home page.

To direct movie to another web page follow this steps:
1. Select the button or keyframe we want to assign the action to.
2. Open the Action panel.
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3. Add the getURL action to script. After adding the action to script, the
parameter text boxes appear above the script pane.

4. In the URL field, enter the URL of the page to open when action executes.
Enter full path for the URL, for example: http://www.google.com

5. Click the button to the right of the window field and choose one of the
following:
 Self: opens the URL in the same window as the link.
 Blank: opens the specified URL in a new browser window. Choose this

option, and your flash movie plays in the background.
 Parent: loads the URL in the window of the frame that called the link.

If the frame isn’t nested, the URL opens in the full browser window.
 Top: loads the URL in the full browser window, removing all frames.

6. In the variables field, accept the default Do Not Send or click button to the
right of the field and choose Send Using Get or Send Using Post.
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